Wednesday, August 18, 2010

Application Express 4.0.1 released

Today, Oracle Application Express 4.0.1 was released. This corrects a number of issues discovered in the original Application Express 4.0 release. In the README of the Application Express 4.0.1 patch set, there is a listing of all of the bugs corrected in this patch set. You can view a copy of it here.

We have also repackaged the Oracle Application Express full distribution. If you have never installed or upgraded to Oracle Application Express 4.0, you can download the latest full distribution and install this and you'll have Application Express 4.0.1 out-of-the-box. Since this always creates confusion for customers (do you need the patch set or the full distribution?), use this guide:

  1. If you have Oracle Application Express release 4.0 installed, download the Oracle Application Express 4.0.1 patch set from My Oracle Support and apply it. Look for patch number 9976149. Even though the file is named p9976149_11201_GENERIC.zip, seemingly only for DB 11.2.0.1, it can actually be used against any supported database version running Application Express 4.0.

  2. If you have Oracle Application Express release 3.2.1 or earlier installed (including Oracle HTML DB release 1.5), download and install the entire Oracle Application Express 4.0.1 release from the Oracle Technology Network (OTN).

  3. If you do not have Oracle Application Express installed, download and install the entire Oracle Application Express 4.0.1 release from the Oracle Technology Network (OTN).

And how do you determine what version you're running? Well, if you're a DBA, you can connect to the database as SYS using SQL*Plus and issue:

select version from sys.dba_registry where comp_id = 'APEX';

If you can login to the Application Express development environment, you'll see the version number in the lower right of every page.

Oracle Application Express at http://apex.oracle.com had the 4.0.1.00.03 patch set applied on Saturday, August 14, 2010.

4 comments:

Roel said...

That's great, but why does my "Available Updates" region on my APEX Home page says "System is up-to-date". Shouldn't it say: Patch 4.0.1 is available or something like that?

Roel

Patrick Wolf said...

Hi Roel,

for me it's showing "Patch Set 4.0.1.00.03 available" ;-)

Thanks
Patrick

Joel R. Kallman said...

Roel - Thanks for pointing this out. Patrick was on vacation yesterday, hence the delay on this. He's got one of those good European jobs where you get like 18 weeks vacation per year....like you. ;)

Joel

jeffkemponoracle.com said...

It looks like the patch is only available to paid-up Oracle customers. My "Available Updates" refers to 4.0.1.00.03 but the link goes to a page that says "download p9976149_11201_GENERIC.zip" but doesn't say where from. Too bad for those of us who don't have a MOS account!