Thursday, January 21, 2016

If you use Internet Explorer, change is coming for you in Oracle Application Express 5.1

With the ever-changing browser landscape, we needed to make some tough decisions as to which browsers and versions are going to be deemed "supported" for Oracle Application Express.  There isn't enough time and money to support all browsers and all versions, each with different bugs and varying levels of support of standards.

A position that's been adopted for the Oracle Cloud services and products is to support the current version of a browser and the prior major release.  We are adopting this same standard for Oracle Application Express beginning with Oracle Application Express 5.1.  This will most likely have the greatest impact on those people who use Microsoft Internet Explorer. 

Beginning with Oracle Application Express 5.1, the planned minimum version of Internet Explorer to both build and deploy applications, will be Internet Explorer 11.  I say "planned", because it's possible (but unlikely) that Microsoft releases a new browser version prior to the release of Oracle Application Express 5.1.

Granted, even Microsoft themselves has already dropped support for any version of IE before Internet Explorer 11.  And with no security fixes planned for any version of IE prior to Internet Explorer 11, hopefully this will be enough to encourage all users of IE to adopt IE 11 as their minimum version.

6 comments:

APEX Developer In Virgina said...

But Microsoft DID release Edge a while back, doesn't that count??

Mahmoud Moumani said...

That's nice,
I use Chrome to develop the applications,
but still waiting for the 5.1 for RTL support in in universal theme

sarath babu said...

Hi;
We are logging into Apex from SAP-BO Hyperlink.
We have migrated Oracle Apex 4.2 apps to Apex 5.0.3
Our Apex Applications are working fine from Chrome. But not in IE11. Mainly
1)If we click on "Apply Changes" nothing happens. 2)If we click on "Home" Tab, Nothing Happens.

Joel R. Kallman said...

Hi Sarath,

Can you please see if there are any JavaScript errors on the page?

Joel

sarath babu said...

In IE11, We got this Error: After we send "Submit" Request from Apex Pages, We get the following Errors:
1) " Object doesn't support property or method 'submit' " . 2) Object doesn't support property or method 'addEventListener'.
As we are using Apex in iFrames from BO, We have following Configuration in Apex Browser Security Attributes: 1)Cache : Enabled 2)Embed in iFrames: Allow 3)HTML Escaping Mode: Extended.

Joel R. Kallman said...

Hi Sarath,

Please see this discussion forum thread:

https://community.oracle.com/thread/3947890

I hope this helps.

Joel